A better Python REPL

ptpython A better Python REPL pip install ptpython Ptpython is an advanced Python REPL. It should work on all Python versions from 2.6 up to 3.7 and work cross platform (Linux, BSD, OS X and Windows). Note: this versi

Related Repos



inclement Pyonic interpreter A Python interpreter interface for mobile devices. Pyonic interpreter is available for Android on Google Play, for Python 2 or Python 3. The app can also be run under Kivy on the desktop (Linux, OS X/macOS, Win
 

scvalencia Coddie: An Interpreter for Extended Relational Algebra Inspired by the simplicity and elegance of both the Scheme programming language, and the relational algebra formal system, Coddie is an interpreter with Lisp-like syntax that
 

asrp pymetaterp This is a python AST builder that uses no Python modules. A longer stackless version is available for easier porting. single_file.py is a stand-alone 502 lines script. Its (also) just another parsing expression gramma
 

oriontransfer PL/0 Language Tools The PL/0 Language Tools serve as an example of how to construct a compiler. The language 'PL/0' was originally introduced in the book "Algorithms + Data Structures = Programs", by Niklaus Wirth in 1975. Thi
 

yasn77 whitepy Whitespace interpreter written in Python3 for my final Open University project (TM470) Install and Usage Once installed, run whitepycli with a whitespace source file as an argument. Using pip $
 

PiotrDabkowski Pure Python JavaScript Translator/Interpreter Everything is done in 100% pure Python so it's extremely easy to install and use. Supports Python 2 & 3. Full support for ECMAScript 5.1, ECMA 6 support is still experimental.
 

bpython bpython: A fancy curses interface to the Python interactive interpreter bpython is a lightweight Python interpreter that adds several features common to IDEs. These features include syntax highlighting, expected parame
 
Popular
7.6k

RustPython RustPython A Python-3 (CPython >= 3.5.0) Interpreter written in Rust 🐍 😱 🤘 . Usage Check out our online demo running on WebAssembly. RustPython requires Rust latest st